Using integrated logins – Sybase 12.4.2 User Manual

Page 107

Advertising
background image

CHAPTER 2 Running Adaptive Server IQ

87

Using integrated logins

Several steps must be implemented in order to connect successfully via an
integrated login.

❖

To use an integrated login:

1

Enable the integrated login feature in a database by setting the value of the
LOGIN_MODE database option to either

Mixed

or

Integrated

(the option

is case insensitive), in place of the default value of

Standard

. This step

requires DBA authority).

2

Create an integrated login mapping between a user profile and an existing
database user. This can be done using a SQL statement.

3

Connect from a client application in such a way that the integrated login
facility is triggered.

Each of these steps is described in the sections below.

Enabling the integrated login feature

The LOGIN_MODE database option determines whether the integrated login
feature is enabled. As database options apply only to the database in which they
are found, different databases can have a different integrated login setting even
if they are loaded and running within the same server.

The LOGIN_MODE database option accepts one of following three values
(which are case insensitive).

•

Standard

This is the default setting, which does not permit integrated

logins. An error occurs if an integrated login connection is attempted.

•

Mixed

With this setting, both integrated logins and standard logins are

allowed.

•

Integrated

With this setting, all logins to the database must be made

using integrated logins.

Warning!

Setting the LOGIN_MODE database option to Integrated restricts

connections to only those users who have been granted an integrated login
mapping. Attempting to connect using a user ID and password generates an
error. The only exception to this are users with DBA authority (full
administrative rights).

Advertising