Upgrade and downgrade considerations for failover, Failback, Failback configurations in access gateway – Dell POWEREDGE M1000E User Manual

Page 68

Advertising
background image

48

Access Gateway Administrator’s Guide

53-1001760-01

Failback

3

3. Enter the ag

--

failoverdisable -pg pgid command to disable failover.

switch:admin> ag --failoverdisable -pg 3

Failover policy is disabled for port group 3

Upgrade and downgrade considerations for Failover

Consider the following when upgrading or downgrading Fabric OS versions.

•

Downgrading to Fabric OS v6.3.0 or earlier is supported.

•

Upgrading from v6.3.0 to v6.4.0 or downgrading from v6.4.0 to v6.3.0 will not change failover
settings.

Failback

Failback policy provides a means for hosts that have failed over to automatically reroute back to
their intended mapped N_Ports when these N_Ports come back online. Failback policy is an
attribute of an N_Port and is enabled by default when a port is locked to the N_Port.

Only the originally mapped F_Ports fail back. In the case of multiple N_Port failures, only F_Ports
that were mapped to a recovered N_Port experience failback. The remaining F_Ports are not
redistributed.

NOTE

For port-based mapping, the Failback policy must be enabled on an N_Port for failback to occur. For
device-based mapping, the Failback policy has no effect. If a device is mapped to a port group, it will
always fail over to an online N_Port in the port group (or secondary N_Port if configured) and will
remain connected to this failover N_Port when the original N_Port comes back online.

Failback configurations in Access Gateway

The following sequence describes how a failback event occurs:

•

When an N_Port comes back online, with Failback enabled, the F_Ports that were originally
mapped to it are temporarily disabled.

•

The F_Port is rerouted to the primary mapped N_Port, and then re-enabled.

•

The host establishes a new connection with the fabric.

NOTE

The failback period is quite fast and rarely causes an I/O error at the application level.

Example : Failback

In Example 3, described in

Figure 11

on page 49, the Access Gateway N_1 remains disabled

because the corresponding F_A1 port is offline. However, N_2 comes back online. See

Figure 10

on page 45 for the original fail over scenario.

The ports F_1 and F_2 are mapped to N_1 and continue routing to N_3. Ports F_3 and F_4, which
were originally mapped to N_2, are disabled and rerouted to N_2, and then enabled.

Advertising