How to use netconf, Protocols and standards, Fips compliance – H3C Technologies H3C MSR 5600 User Manual

Page 144

Advertising
background image

131

<filter type="subtree">

<top xmlns="http://www.h3c.com/netconf/data:1.0">

<Ifmgr>

<Interfaces>

<Interface/>

</Interfaces>

</Ifmgr>

</top>

</filter>

</get-bulk>

</rpc>

</env:Body>

</env:Envelope>

How to use NETCONF

You can use NETCONF to manage and configure devices by using the methods in

Table 16

.

Table 10 NETCONF methods for configuring the device

Configuration tool

Login method

Remarks

CLI

•

Console port

•

SSH

•

Telnet

To implement NETCONF operations, copy valid
NETCONF messages to the CLI in XML view.
This method is suitable for R&D and test
purposes.

Custom Web interface

N/A

To use this method, you must enable NETCONF
over SOAP.

Protocols and standards

•

RFC 3339, Date and Time on the Internet: Timestamps

•

RFC 4741, NETCONF Configuration Protocol

•

RFC 4742, Using the NETCONF Configuration Protocol over Secure SHell (SSH)

•

RFC 4743, Using NETCONF over the Simple Object Access Protocol (SOAP)

•

RFC 5277, NETCONF Event Notifications

•

RFC 5381, Experience of Implementing NETCONF over SOAP

•

RFC 5539, NETCONF over Transport Layer Security (TLS)

•

RFC 6241, Network Configuration Protocol

FIPS compliance

The device supports the FIPS mode that complies with NIST FIPS 140-2 requirements. Support for features,
commands, and parameters might differ in FIPS mode (see Security Configuration Guide) and non-FIPS

mode.

Advertising
This manual is related to the following products: