D in, Table 17 – Brocade Network Advisor IP User Manual v12.1.0 User Manual

Page 100

Advertising
background image

46

Brocade Network Advisor IP User Manual

53-1002947-01

IP discovery overview

4

Table 17

provides a list of MIB support required for third-party devices.

TABLE 17

Required MIB support for third-party devices

IETF standard

MIB name

Required MIB object

Data collected

RFC 1213

MIB-II

mib-2.system
mib-2.interfaces.ifTable
mib-2.ip.ipAddrTable

From mib-2.interfaces.ifTable for interface
level information:

•

ifName/ifDescr

•

ifAlias

•

ifType

•

ifMtu

•

ifSpeed

•

ifPhysAddress

•

ifAdminStatus

•

ifOperStatus

•

ifLastChange

From mib-2.ip.ipAddrTable for IP subnet
information:

•

ipAdEntAddr

•

ipAdEntNetMask

From mib-2.ip.ipAddrTable for Layer 3
topology information:

•

ipForwarding

RFC 2465

IPv6-MIB

ipv6MIBObjects
ipv6NetToMediaTable
ipv6MIBObjects.ipv6AddrTable

From ipv6MIBObjects and
ipv6NetToMediaTable for interface level
information:

•

ifName/ifDescr

•

ifAlias

•

ifType

•

ifMtu

•

ifSpeed

•

ifPhysAddress

•

ifAdminStatus

•

ifOperStatus

•

ifLastChange

From ipv6MIBObjects.ipv6AddrTable for IP
subnet information:

•

ipv6AddrAddress

•

ipv6AddrPfxLength

RFC 2863

IF-MIB

ifMIBObjects.ifXTable

From ifMIBObjects.ifXTable for interface level
information:

•

ifName/ifDescr

•

ifAlias

•

ifType

•

ifMtu

•

ifSpeed

•

ifPhysAddress

•

ifAdminStatus

•

ifOperStatus

•

ifLastChange

Advertising