CANOGA PERKINS 9175 Configuration Guide User Manual

Page 217

Advertising
background image

CanogaOS Configuration Guide

31-11

ingress interface.

DUT(config)# ip access-list ip-acl1
DUT(config-ip-acl)# permit any 10.1.0.0 0.0.255.255 any
DUT(config-ip-acl)# exit
DUT(config)# ip access-list ip-acl2
DUT(config-ip-acl)# permit any host 11.3.1.1 any
DUT(config-ip-acl)# exit
DUT(config)# qos aggregate-policer transmit1 color-blind cir 48000 cbs 8000
ebs 10000 drop-color red
DUT(config)# class-map cmap1
DUT(config-cmap)# match access-group ip-acl1
DUT(config-cmap)# exit
DUT(config)# class-map map cmap2
DUT(config-cmap)# match access-group ip-acl2
DUT(config-cmap)# exit
DUT(config)# policy-map aggflow1
DUT(config-pmap)# class-map cmap1
DUT(config-pmap-c)# policer-aggregate transmit1
DUT(config-pmap-c)# exit
DUT(config-pmap)# class-map cmap2
DUT(config-pmap-c)# set priority 56 color green
DUT(config-pmap-c)# police-aggregate transmit1
DUT(config-pmap-c)# exit
DUT(config-pmap)# exit
DUT(config)# interface eth-0-1
DUT(config-if)# service-policy input aggflow1
DUT(config-if)# exit

31.4.5 Configure QoS Mapping tables

CoS-Priority-Color Map
The following shows modifying a CoS-Priority-Color map. This map is used to generate
an internal priority color value from CoS during classification; this value determines the
QoS action in the DUT, such as selecting one of the eight egress queues, etc.

• configure

terminal.

• qos map cos-pri-color cos <0-7> to PRIORITY COLOR to modify the

CoS-Priority-Color Map. PRIORITY = priority value, range is 0-63. COLOR = color
values, red, yellow or green

The following example shows mapping cos 1 to priority 63 color green

DUT# configure terminal
DUT(config)# qos map cos-pri-color cos 1 to 63 green


IP-Precedence-Priority-Color Map
The following shows modifying an IP-Precedence-Priority-Color map. This map is used
to generate an internal priority color value from IP-Precedence during classification; this
value determines the QoS action in the DUT, such as selecting one of the eight egress
queues, etc.

• configure

terminal.

• qos map ip-prec-pri-color ip-prec <0-7> to PRIORITY COLOR to modify the

CoS-Priority-Color Map. PRIORITY = priority value, range is 0-63. COLOR = color
values, red, yellow or green

The following example shows mapping ip-prec 1 to priority 63 color green, and trust CoS
in the interface eth-0-1 ingress for classification.

DUT# configure terminal

Advertising