Netconf support in network os, Table 2 – Brocade Network OS NETCONF Operations Guide v4.1.1 User Manual

Page 39

Advertising
background image

Network OS NETCONF Operations Guide

7

53-1003231-02

NETCONF support in Network OS

1

•

RFC 6020, “YANG - A Data Modeling Language for the Network Configuration Protocol
(NETCONF)
”

•

RFC 6021, “Common YANG Data Types”

NETCONF support in Network OS

This section describes the support in Network OS for NETCONF features.

Table 2

describes the degree of support in Network OS for each NETCONF RPC. For details of the

RPCs listed in

Table 2

, refer to RFC 4741.

To retrieve operational state data, Network OS supports two mechanisms: the Brocade custom
RPCs and the custom action mechanism. Refer to

Chapter 2, “Basic NETCONF Operations,”

for

details about Brocade customized RPCs and the custom action mechanism.

TABLE 2

NETCONF RPCs supported in Network OS

RPC

Function

Support in Network OS

<copy-config>

Copies the startup configuration to
the running configuration, copies the
running configuration to the startup
configuration, copies the startup or
running configuration to a remote file,
or copies the remote file to the
startup or running configuration.

Use <bna-config-cmd> custom RPC instead.

<close-session>

Terminates the current NETCONF
session gracefully.

Supported

<delete-config>

Deletes a configuration datastore.

Supported

<edit-config>

Makes changes to a configuration
datastore.

The merge and delete operations are
supported. The replace and create operations
are not supported.
The <running> target is supported. The
<candidate> target is not supported.
The <error-option> element supports only the
stop-on-error value. It does not support the
continue-on-error or rollback-on-error values.

<get>

Retrieves the entire or partial
configuration data and operational
state data.

Retrieval of configuration data is supported.
Retrieval of operational state data is not
supported through the <get> RPC. Operational
state data is retrieved using the Brocade custom
RPCs and the custom action mechanism.
Configuration state data is not modeled in the
data models.

<get-config>

Retrieves the entire or partial
configuration data.

Supported

<kill-session>

Forces the termination of a NETCONF
session.

Supported

<lock>

Locks a configuration datastore.

Not supported

<unlock>

Unlocks a configuration datastore.

Not supported

Advertising